Ubuntu に 最新の gradle をインストールする


私が Ubuntu に最新の gradle をインストールした方法です。


経緯

Ubuntu のリポジトリにある gradle のバージョンは 1.4 です。 この gradle version 1.4 で gradle init を実行するとエラーが表示されます。 現在流布している gradle の情報は gradle 2 をベースとしているため、 これでは公開されている情報を試すことができません。

そこで、 gradle の最新バージョンをインストールすることにしました。

環境

  • Ubuntu 14.04.3 LTS

インストール方法

既存の gradle のアンインストール

gradle が2種類存在するとややこしいので 既にインストールしている場合は gradle を削除します。

リポジトリを追加

apt で使用する gradle のリポジトリを追加します。

これを実行すると、次のような出力が出ます。 Yes/No を()かれるので Enter を押して進めます。

gpg でキーが作成されます。

リポジトリの追加が終わったら、 リポジトリのキャッシュを更新しておきます。

gradle をインストール

gradle をインストールします。 まずは gradle のパッケージを調べます。

私の環境では次のように出力されました。

gradle-2.10 をインストールします。